Avidyne Homepage
Forum Home Forum Home > Avidyne General > IFD 5 Series & IFD 4 Series Touch Screen GPS/NAV/COM
  New Posts New Posts RSS Feed - 10.2.1 Broadcast Products Not Received
  FAQ FAQ  Forum Search   Register Register  Login Login

10.2.1 Broadcast Products Not Received

 Post Reply Post Reply
Author
Message
jimmyz80 View Drop Down
Groupie
Groupie
Avatar

Joined: 24 Jul 2016
Location: Folsom, CA
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote jimmyz80 Quote  Post ReplyReply Direct Link To This Post Topic: 10.2.1 Broadcast Products Not Received
    Posted: 23 Mar 2018 at 5:02pm
Finally got in a long'ish flight today after having installed 10.2.1 a few weekends ago.  Now I constantly have the following message showing up in my Alerts page, and subsequently flagging "MSG" on my PFD.

Broadcast Products Not Received: SIGMETs

I'm not sure what to make of this, since it stayed up for over an hour at a time, and I never had it occur back on 10.2.0.  It's super annoying to always have a message queued up that can't be cleared, since it makes the MSG flag on my PFD useless because it's on all the time now.

When installing 10.2.1 we made sure to copy all of the input/output settings exactly.  See photos below for screenshot and settings page.  Note that the screenshots are actually from 10.2.0 before we did the upgrade.  We used these photos as reference to set the new settings, so they should be the same unless I fat fingered something.








Edited by jimmyz80 - 23 Mar 2018 at 5:03pm
2006 Cirrus SR22 - IFD540 IFD440 DFC90 AXP322 MLB100
Back to Top
dmtidler View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Feb 2016
Location: USA
Status: Offline
Points: 616
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmtidler Quote  Post ReplyReply Direct Link To This Post Posted: 23 Mar 2018 at 9:51pm
I have mentioned the same issue regarding the SIGMETs and AIRMET products not being received in one of the 10.2.1.0 threads. In past month, most flights have had one or the other (sometimes both) flagged. I have had a few flights that have received both SIGMETs and AIRMETs and consequently no advisory message.

I emailed Avidyne Tech support regarding this issue a few weeks ago; it was raised to engineering with no official reply as of today. As best as I can determine, I am getting the broadcast products fine (all other FIS-B and TIS-B are received). It appears sw10.2.1.0 is more aggressive about letting the user know that these products are not being receive as I too, never saw these messages in the two years prior to upgrading to sw10.2.1.0.

I found an ADSB reference that indicates that SIGMETs and AIRMETs are broadcast every 5 minutes if they are within 100NM of the ADSB tower. Effectively, this means SIGMETs and AIRMETs are received within 100 NM to 500 NM of the aircraft depending on how many ADSB towers the airplane is receiving (altitude). Based on the general weather I flew most of my flights in (VFR 3500 AGL and below), it appears my MLB100/SkyTrax100 and IFD540 was actually functioning properly; however, I agree there seems to be a change in the IFD540 reporting behavior. 


Back to Top
Ibraham View Drop Down
Senior Member
Senior Member


Joined: 21 May 2016
Location: KHWO
Status: Offline
Points: 357
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ibraham Quote  Post ReplyReply Direct Link To This Post Posted: 23 Mar 2018 at 10:20pm
I believe that starting with 10.2, the preferred Skytrax setup for both traffic and weather is through RS232 and not ARINC 429

INPUT
SkyTrax Trfc+Wx 
Serial traffic and weather data information from the Avidyne Skytrax100/MLB100

OUTPUT
SkyTrax Trfc+Wx
Serial traffic and weather data information to the Avidyne Skytrax100/MLB100
Back to Top
teeth6 View Drop Down
Senior Member
Senior Member


Joined: 10 Mar 2014
Status: Offline
Points: 741
Post Options Post Options   Thanks (0) Thanks(0)   Quote teeth6 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Mar 2018 at 10:58pm
I just installed 10.2.1 today but was getting those messages fairly frequently with 10.2 also.  In each case, it seemed to be the Sigmets that were not being received.
Back to Top
jimmyz80 View Drop Down
Groupie
Groupie
Avatar

Joined: 24 Jul 2016
Location: Folsom, CA
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote jimmyz80 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Mar 2018 at 11:03pm
I believe you're correct.  I was just looking through the 10.2.1 installation manual, and the service bulletin for the MLB100 I had done awhile back, and both seem to say use Skytrax Trfc & Wx In/Out on RS-232, and to not use the ARINC 429 channel.

I guess I should change those, but I'll wait for someone from Avidyne to respond and confirm.  Looks like something my dealer must have not been aware of during my 10.2.0 upgrade. :/
2006 Cirrus SR22 - IFD540 IFD440 DFC90 AXP322 MLB100
Back to Top
dmtidler View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Feb 2016
Location: USA
Status: Offline
Points: 616
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmtidler Quote  Post ReplyReply Direct Link To This Post Posted: 24 Mar 2018 at 9:06am
I was going to mention your channel setup also but stopped because I saw you also have AIRINC 429 traffic from the MLB100 on your IFD440; however, no apparent RS-232 channels to/from your MLB100 on your IFD440. I would think CrossSync would deliver that info from the IFD540 as it essentially does with the IFD100. I only have a single IFD540 in my setup which makes a little unfamiliar with all of the nuances of CrossSync.
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 2163
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2018 at 11:56am
The 10.2.1 release notes mention "Improved AIRMET/SIGMET decoding".  Part of the improvement was in the tracking of report reception in order to determine whether data is stale.  The IFD is supposed to receive SIGMETs every five minutes.  If 20 minutes go by without the IFD having received a valid report, the alert gets generated.  So what you're seeing now is an accurate indication of that condition.
Steve Lindsley
Avidyne Engineering
Back to Top
dmtidler View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Feb 2016
Location: USA
Status: Offline
Points: 616
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmtidler Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2018 at 12:30pm
Thanks!

I’ve also seen the stale indications for AIRMETs, SIGMETs, and TFRs.
Back to Top
jimmyz80 View Drop Down
Groupie
Groupie
Avatar

Joined: 24 Jul 2016
Location: Folsom, CA
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote jimmyz80 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2018 at 1:34pm
I agree with calling out stale information, but I really dislike the fact that it keeps the alert and MSG indicators on all the time.  To me, I need those to warn me about things that need my attention (tank changes, waypoints, etc.), there's literally nothing that I as a pilot can do to clear these FIS-B problems/messages.  I have a support case open on this now, so we'll see where that goes...
2006 Cirrus SR22 - IFD540 IFD440 DFC90 AXP322 MLB100
Back to Top
teeth6 View Drop Down
Senior Member
Senior Member


Joined: 10 Mar 2014
Status: Offline
Points: 741
Post Options Post Options   Thanks (0) Thanks(0)   Quote teeth6 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2018 at 7:20pm
Originally posted by AviSteve AviSteve wrote:

The 10.2.1 release notes mention "Improved AIRMET/SIGMET decoding".  Part of the improvement was in the tracking of report reception in order to determine whether data is stale.  The IFD is supposed to receive SIGMETs every five minutes.  If 20 minutes go by without the IFD having received a valid report, the alert gets generated.  So what you're seeing now is an accurate indication of that condition.


That makes sense but I wonder why the sigmets are stale on every single flight now.  I realize it could have been like this before 10.2.1 with the IFD just not warning us but it's annoying to see on all my flights.  Is this just a function of ADS-B not putting the report as frequently as it should?
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 2163
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 27 Mar 2018 at 9:08am
Originally posted by teeth6 teeth6 wrote:

Originally posted by AviSteve AviSteve wrote:

The 10.2.1 release notes mention "Improved AIRMET/SIGMET decoding".  Part of the improvement was in the tracking of report reception in order to determine whether data is stale.  The IFD is supposed to receive SIGMETs every five minutes.  If 20 minutes go by without the IFD having received a valid report, the alert gets generated.  So what you're seeing now is an accurate indication of that condition.


That makes sense but I wonder why the sigmets are stale on every single flight now.  I realize it could have been like this before 10.2.1 with the IFD just not warning us but it's annoying to see on all my flights.  Is this just a function of ADS-B not putting the report as frequently as it should?
It could be that it is being transmitted by the ground, but the ADS-B receiver is unable to decode it.  I don't really have any way to know that.  Based on the presence of the alert, all I can really tell is that the IFD believes it's not seeing a valid report.
Steve Lindsley
Avidyne Engineering
Back to Top
Freff View Drop Down
Newbie
Newbie
Avatar

Joined: 01 Oct 2015
Status: Offline
Points: 25
Post Options Post Options   Thanks (0) Thanks(0)   Quote Freff Quote  Post ReplyReply Direct Link To This Post Posted: 28 Mar 2018 at 3:00pm
I am getting these SIGMET warnings also since upgrade to 10.2.1

The weather has been relatively good and I don't believe that any SIGMETS existed.    My guess is that once we have some thunderstorms and associated SIGMETS actually issued that the warning will not be present.  
Back to Top
HenryM View Drop Down
Senior Member
Senior Member


Joined: 13 Oct 2017
Location: Texas
Status: Offline
Points: 488
Post Options Post Options   Thanks (1) Thanks(1)   Quote HenryM Quote  Post ReplyReply Direct Link To This Post Posted: 30 Mar 2018 at 9:37pm
I finally got to go flying today after the 10.2.1.0 update and had the same issue. I had an alert I couldn’t get rid of about weather not being received. Traffic from the SkyTrax 100 seemed to be displaying properly. I also saw the flags that represent VFR/MVFR/IFR conditions at at various airports.

Playing with the simulator, I believe I found a way to get rid of the issue. When viewing the map, you can press the Wx Overlay LSK and turn off AIR/SIGMET. In the simulator, this gets rid of the alerts. It makes sense that if there are no AIR/SIGMETS but you ask to display them, you get a message that says you are not receiving them. The simulator does this too.

Edited by HenryM - 30 Mar 2018 at 10:44pm
Back to Top
jimmyz80 View Drop Down
Groupie
Groupie
Avatar

Joined: 24 Jul 2016
Location: Folsom, CA
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote jimmyz80 Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2018 at 12:06pm
Originally posted by HenryM HenryM wrote:

I finally got to go flying today after the 10.2.1.0 update and had the same issue. I had an alert I couldn’t get rid of about weather not being received. Traffic from the SkyTrax 100 seemed to be displaying properly. I also saw the flags that represent VFR/MVFR/IFR conditions at at various airports.

Playing with the simulator, I believe I found a way to get rid of the issue. When viewing the map, you can press the Wx Overlay LSK and turn off AIR/SIGMET. In the simulator, this gets rid of the alerts. It makes sense that if there are no AIR/SIGMETS but you ask to display them, you get a message that says you are not receiving them. The simulator does this too.

I tried turning off that check box on my IFDs, and my IFD AUX light and PFD MSG indicator still stayed illuminated blue and yellow respectively for the entire multi-hour flight. :(
2006 Cirrus SR22 - IFD540 IFD440 DFC90 AXP322 MLB100
Back to Top
teeth6 View Drop Down
Senior Member
Senior Member


Joined: 10 Mar 2014
Status: Offline
Points: 741
Post Options Post Options   Thanks (0) Thanks(0)   Quote teeth6 Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2018 at 12:44pm
I don't believe it is just that there are no Sigmets to receive.  It seems the Skytrax is not getting info regarding Sigmets which prompts the message.  Even when there are no Airmets, the Wx page in AUX does say that Airmets are X min old and therefore there is no alert.  The Sigmet age is always not received which after 10 min prompts the warning.  I think Avidyne is now aware this is an issue and is working on it.  It could be an ADS-b issue and has probably been present all along but we never knew it since 10.2 didn't fire off an alert.
Back to Top
teeth6 View Drop Down
Senior Member
Senior Member


Joined: 10 Mar 2014
Status: Offline
Points: 741
Post Options Post Options   Thanks (0) Thanks(0)   Quote teeth6 Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2018 at 6:35pm
Has a determination been made as to the cause of the "Broadcast Products not Received" message along with the alert when Sigmets are not received 10 min into each flight?  If so, is a fix in the works?
Back to Top
dmtidler View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Feb 2016
Location: USA
Status: Offline
Points: 616
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmtidler Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2018 at 7:54pm
I've seen the message for AIRMETs, SIGMETs, or both AIRMETs and SIGMETs not being received. I've also not seen the message display when there were AIRMETs and SIGMETs in my local area; hence, AIRMETs and SIGMETs were received by my MLB100 / Skytrax100.
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 2163
Post Options Post Options   Thanks (2) Thanks(2)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2018 at 9:07am
Originally posted by teeth6 teeth6 wrote:

Has a determination been made as to the cause of the "Broadcast Products not Received" message along with the alert when Sigmets are not received 10 min into each flight?  If so, is a fix in the works?
The problem is that the system cannot determine whether the data hasn't been received because there is a problem with the datalink or because there are no active *METS.  We have identified a method that we can use to tell the difference and have an implementation plan.  Currently scheduled for 10.3.
Steve Lindsley
Avidyne Engineering
Back to Top
teeth6 View Drop Down
Senior Member
Senior Member


Joined: 10 Mar 2014
Status: Offline
Points: 741
Post Options Post Options   Thanks (0) Thanks(0)   Quote teeth6 Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2018 at 9:45am
Excellent!  Thank you Steve.  I must be lucky enough to have always flown when there were no active *METS as I've gotten the warning on every flight since 10.2.1


Edited by teeth6 - 19 May 2018 at 9:48am
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.078 seconds.