Print Page | Close Window

TAS intermittent fault

Printed From: Avidyne
Category: Avidyne General
Forum Name: TAS600 Systems and ADS-B
Forum Description: Topics related to the Avidyne TAS600 Traffic Advisory Systems and ADS-B
URL: http://forums.avidyne.com/forum_posts.asp?TID=1796
Printed Date: 11 Jul 2020 at 4:33pm
Software Version: Web Wiz Forums 12.01 - http://www.webwizforums.com


Topic: TAS intermittent fault
Posted By: oskrypuch
Subject: TAS intermittent fault
Date Posted: 07 Jul 2019 at 6:02pm
I am seeing, perhaps once every other flight, a stereotypical five second fault warning on my IFD, and simultaneously on my ASPEN panel, indicating that there is a problem with the traffic data.

I have only a TAS605A supplying traffic data.

The fault occurs, and then clears, without doing anything else. I've never seen it more than once in a flight. It seems to happen more often on takeoff, only once seen at cruise.

Any ideas as to what is happening? Should I be concerned?

BTW, are there any firmware updates, since the original release 605A version?

* Orest



Replies:
Posted By: AviSteve
Date Posted: 08 Jul 2019 at 1:28pm
The current software is 2.0.3 for the TAS605A.  If you're not at that version, we recommend that you upgrade to that and then report back if the faults are still present.

-------------
Steve Lindsley
Avidyne Engineering


Posted By: oskrypuch
Date Posted: 08 Jul 2019 at 4:07pm
OK, will do.

Is the only way to discern the firmware level, by logging in on the serial port with a laptop?

* Orest


Posted By: oskrypuch
Date Posted: 08 Jul 2019 at 5:05pm
Disregard, we are not at 2.0.3, and looks like it fixes exactly this problem ...

" ... fix for a bug, that may result in no traffic, if using the RS-232 interface."

Will report back.

* Orest



Posted By: ddgates
Date Posted: 11 Jul 2019 at 8:49am
When the boxes were sent in for the -A revision, what was the software level installed when they returned?

-------------
David Gates


Posted By: oskrypuch
Date Posted: 07 Sep 2019 at 5:47pm
Originally posted by AviSteve AviSteve wrote:

The current software is 2.0.3 for the TAS605A.  If you're not at that version, we recommend that you upgrade to that and then report back if the faults are still present.


Now updated to the latest firmware.

The same issue still continues, an intermittent (perhaps once an hour) of TAS fault, traffic not available, simultaneously on the ASPEN & IFD. Lasts about 5 sec on the ASPEN, fault message persists for 11 sec on the IFD. Suspect that just reflects the programmed error message latency on each device. Always exactly the same cadence.

* Orest


Posted By: AviSteve
Date Posted: 09 Sep 2019 at 4:01pm
Originally posted by oskrypuch oskrypuch wrote:

Now updated to the latest firmware.

The same issue still continues, an intermittent (perhaps once an hour) of TAS fault, traffic not available, simultaneously on the ASPEN & IFD. Lasts about 5 sec on the ASPEN, fault message persists for 11 sec on the IFD. Suspect that just reflects the programmed error message latency on each device. Always exactly the same cadence.

* Orest
That's too bad, I really thought updating the software would clear it up.  I'll have our surveillance group look into it further.  Stand by...


-------------
Steve Lindsley
Avidyne Engineering


Posted By: oskrypuch
Date Posted: 03 Oct 2019 at 4:04pm
Issue still remains.

I pushed the "status" button during one of these faults, and it said "Ground Mode", instead of "No Advisories".

Is that a clue?

* Orest


Posted By: AviSteve
Date Posted: 04 Oct 2019 at 11:33am
No, the ground mode annunciation is unrelated.

However, there is good news.  The surveillance team has been looking into it and they did find an issue in the TAS-A that can cause unexpected resets of the TAS system.  It takes about 10 seconds from initiating the reset to return to full operational status.  Once the display detects the lost connection it will flag a failure, and then recover when the reset is complete and the link is restored.  They have implemented a fix for this issue and hope to have the fix released within the next two weeks.



-------------
Steve Lindsley
Avidyne Engineering


Posted By: ddgates
Date Posted: 04 Oct 2019 at 12:29pm
Does that mean that we are all going to have to update our TAS- boxes?

Does that mean sending back?

Would there be any other improvements included in new software?

Thanks


-------------
David Gates


Posted By: AviSteve
Date Posted: 04 Oct 2019 at 1:50pm
All good questions that I don't have answers for at this point.  Stay tuned.

-------------
Steve Lindsley
Avidyne Engineering


Posted By: oskrypuch
Date Posted: 04 Oct 2019 at 3:43pm
Originally posted by AviSteve AviSteve wrote:

...The surveillance team has been looking into it and they did find an issue in the TAS-A that can cause unexpected resets of the TAS system.  It takes about 10 seconds from initiating the reset to return to full operational status.


Yes, that is precisely the timing on the recovery time. Sounds encouraging. Awaiting the potential solution with bated breath.

As always, thanks much!

* Orest


Posted By: oskrypuch
Date Posted: 27 Dec 2019 at 10:41pm
Originally posted by AviSteve AviSteve wrote:

Posted: 04 Oct 2019

....They have implemented a fix for this issue and hope to have the fix released within the next two weeks.



Any further word? It has been a couple of months.

* Ores


Posted By: AviSteve
Date Posted: 02 Jan 2020 at 9:56am
Originally posted by oskrypuch oskrypuch wrote:

Originally posted by AviSteve AviSteve wrote:

Posted: 04 Oct 2019

....They have implemented a fix for this issue and hope to have the fix released within the next two weeks.



Any further word? It has been a couple of months.

* Ores
Yes it has been released.  I'm working on getting further details on how you would get the update, but I didn't want this post to linger any longer.  I'll post again when I get those details.


-------------
Steve Lindsley
Avidyne Engineering


Posted By: oskrypuch
Date Posted: 02 Jan 2020 at 5:09pm
Thanks.


Posted By: AviSteve
Date Posted: 09 Jan 2020 at 2:15pm
Have your dealer take a look at Service Bulletin 601-00185-017.  The micro-SD card has to be pulled and reprogrammed.

-------------
Steve Lindsley
Avidyne Engineering


Posted By: oskrypuch
Date Posted: 09 Jan 2020 at 10:11pm
Thanks.

* Orest



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.01 - http://www.webwizforums.com
Copyright ©2001-2018 Web Wiz Ltd. - https://www.webwiz.net