Print Page | Close Window

IFD100 drops Wifi connection

Printed From: Avidyne
Category: Avidyne General
Forum Name: IFD100 Mobile App
Forum Description: Topics on Avidyne's IFD100 Mobile App
URL: http://forums.avidyne.com/forum_posts.asp?TID=1899
Printed Date: 12 Aug 2020 at 5:38am
Software Version: Web Wiz Forums 12.01 - http://www.webwizforums.com


Topic: IFD100 drops Wifi connection
Posted By: brou0040
Subject: IFD100 drops Wifi connection
Date Posted: 24 Nov 2019 at 8:09pm
I decided to buy a dedicated iPad just for the IFD100 capability.  As far as I know/understand, I have it all configured properly, but it constantly drops its connection with my IFD540.

I have IFD Type set to IFD540, IFD Chassis set to #1, which was the same as the IFD540 Sys ID.  I only have 1 iPad had had iPad # set to 1.  I had WIFI ADS-B Support turned on and never thought to disable that during troubleshooting.  I'm not sure what the does anyways, I haven't found any information on that setting.  I only have a stratux providing ADS-B with no panel source.

This is what I've tried to troubleshoot the issue:
  • I have two networks setup on the IFD, the default LIO_WIFI that I did not modify, then a stratux set up as Remote Wi-Fi and the appropriate PSK.
  • I turned off different things in the cockpit one at a time on my last flight to see if anything changed the connection behavior --> nothing worked
    • Turned off all phones
    • Turned off SPOT
    • Turned off other tablets
    • Unplugged cigar lighter charger for stratux
    • Unplugged iPad from the charger
    • Unplugged panel power to USB charger
    • Turned off second nav/com
    • Changed orientation of the iPad in the mount
    • Turned iPad bluetooth off
    • Turned IFD540 bluetooth off
  • When I set the IFD540 to LIO_WIFI in the aux/networking field, it sometimes would connect for about 2 seconds before it dropped connectivity.
  • When I set the IFD540 to stratux (when not powered down for troubleshooting), I could get it to work for about 1-2 minutes before it would lose connectivity.
    • The Wifi symbol on the iPad would be green and solid for a short while, then would start to flicker a grey crossed out circle symbol on top of it gradually getting more steady, then it would lose connectivity.
  • Once it lost Wifi connectivity with the IFD540, it never regained it without user intervention.
    • I would swipe down from the upper right to turn off Wifi, wait a few seconds, then turn wifi back on, then the behavior would usually repeat --> maybe 2 secs if anything while on LIO_Wi-Fi or ~ 1-2 min when on stratux.

Other info:
  • IFD540 SW 10.2.3.1
  • IFD100 SW 10.2.4.1 (app version 10.2.8)
  • Current NavData on both
  • "Renewed" iPad mini3 (128 GB, Wifi, cellular, but with no sim card)
  • iPad OS 10.4.3
  • Other tablets (2 Android) were completely stable on the stratux network the entire time.

Hopefully the troubleshooting info above is useful to figure out what is going on because I'm excited to get the IFD100 up and running.



Replies:
Posted By: brou0040
Date Posted: 27 Nov 2019 at 8:04pm
No ideas?

Here is a video using the stratux network.
https://youtu.be/AL1hXBMgfu4

Here is a video using the LIO_WIFI network.
https://youtu.be/PCyRo_hAr_s

Here is a picture of the wifi setup from the maintenance mode.
https://drive.google.com/file/d/10KeyF3yG5sz5N9mOYLVfGiHDIzCR-c-B/view?usp=sharing



Posted By: AZ Flyer
Date Posted: 28 Nov 2019 at 12:07am
I would check with Avidyne tech support.  As you are discovering, chasing down a WIFI problem can be extremely time-consuming and frustrating.  

-------------
Stan


Posted By: AZ Flyer
Date Posted: 28 Nov 2019 at 12:32am
P.S.  Check out this thread:   http://forums.avidyne.com/ifd100-release-10-2-8_topic1867.html?KW=iPad+mini" rel="nofollow - http://forums.avidyne.com/ifd100-release-10-2-8_topic1867.html?KW=iPad+mini .  It may be that the iPad Mini 3 is approaching the limits of usability for these kinds of applications.   

-------------
Stan


Posted By: brou0040
Date Posted: 28 Nov 2019 at 12:30pm
Originally posted by AZ Flyer AZ Flyer wrote:

It may be that the iPad Mini 3 is approaching the limits of usability for these kinds of applications.   

I sure hope not, I just bought this for the sole purpose of the IFD100 app and it meets all the requirements specified...  I'll contact customer support tomorrow and see if they can help.

Thanks for the link to the other thread, I saw that when searching the forum.  I was hoping the 3 I got would be OK because it sounded like you had the original.


Posted By: AviSteve
Date Posted: 30 Nov 2019 at 7:34pm
A shot in the dark.  I know you have no sim card, but I don't know what that does to the iPad settings.  I wouldn't think the cellular data option would have any effect, but we recommend that it be turned off.  Same with wifi assist.

-------------
Steve Lindsley
Avidyne Engineering


Posted By: brou0040
Date Posted: 30 Nov 2019 at 7:50pm
Figured I'd try a few more things before calling tech support so I can say I tried a few of the basic steps.

I deleted the IFD100 app and the IFD trainer.  I reloaded the IFD100 app, called Jepp to reset my account, and redownloaded my navdata.

I went back to the airplane to try again, but with the ADS-B Support turned off.  I set the IFD540 to LIO_WIFI gave it a spin.  This time everything worked as expected.  I turned ADS-B support on and it didn't work.  I went back and forth a few times and it seemed repeatable that ADS-B support prevented the app wifi to stay locked up.  I switched the 540 to stratux and tried the same thing.  The wifi connection was solid with LIO_WIFI, but this time it did connect with ADS-B support enabled although the grey crossed out circle would flash over the wifi symbol once and a while although it never completely lost is connection.  I was seeing ADS-B traffic when using ifly, but not when using the IFD100.  I decided to take the airplane out to see if the IFDs needed GPS to display traffic.  Sure enough, I was able to see ADS-B traffic on the IFD100 via my stratux.  I don't recall seeing the grey lined out circle this time.

Bottom line is that it appears that the ADS-B support, which enables traffic via stratux/stratus, makes the wifi connection between the 540 and the 100 less stable.

I don't think I was seeing an ADS-B tower and was only getting data from aircraft in the area.

I was seeing TIS-B crossed out on the MAP page the entire time and going to the datalink page showed no towers.  Even with just the local aircraft, I was overloaded with CAS alerts for aircraft well over 100 miles away.  I'll have to figure out how to limit this so that unimportant traffic doesn't overwhelm the system.

Overall is that I think I'm up and running, especially with ADS-B support disabled, and hopefully the ADS-B support capability will mature in future updates making that another awesome feature.


Posted By: brou0040
Date Posted: 30 Nov 2019 at 7:55pm
Originally posted by AviSteve AviSteve wrote:

A shot in the dark.  I know you have no sim card, but I don't know what that does to the iPad settings.  I wouldn't think the cellular data option would have any effect, but we recommend that it be turned off.  Same with wifi assist.

My Cellular Data setting is grey'd out and says No SIM so I assume it is all disabled - I can't do anything to further disable it since it's greyd out.


Posted By: AviSteve
Date Posted: 30 Nov 2019 at 9:25pm
I also noticed that you have iFly GPS also running.  I'm wondering if that app and the IFD100 are not getting along when ADS-B support is turned on.  Have you tried it without iFly GPS running at the same time?

-------------
Steve Lindsley
Avidyne Engineering


Posted By: brou0040
Date Posted: 30 Nov 2019 at 11:52pm
Originally posted by AviSteve AviSteve wrote:

I also noticed that you have iFly GPS also running.  I'm wondering if that app and the IFD100 are not getting along when ADS-B support is turned on.  Have you tried it without iFly GPS running at the same time?

Yes, tried both with it running and without it running, both last time and today after the reinstall, I couldn't tell any difference.  Only issue is that while the IFD100 is working, and I go to iFly, then come back, it takes a few seconds for the IFD100 to resync to the 540.  In the meantime it loses the entire flight plan and repopulates once it reconnects.

Because it was connecting with ADS-B support while on stratux today, I think the reinstall is at least partially to credit.  I didn't work to isolate it, but I'm assuming that ADS-B Support prevented the connection when trying to use LIO_WIFI.

Does the IFD100 by chance log data in the background where we could send you the logs for more in depth analysis?


Posted By: AviSteve
Date Posted: 01 Dec 2019 at 5:25pm
Originally posted by brou0040 brou0040 wrote:

Does the IFD100 by chance log data in the background where we could send you the logs for more in depth analysis?
Nothing more than the IFD itself.  Also, I'm not sure how you would extract them.


-------------
Steve Lindsley
Avidyne Engineering


Posted By: brou0040
Date Posted: 01 Dec 2019 at 7:46pm
Originally posted by AviSteve AviSteve wrote:

Originally posted by brou0040 brou0040 wrote:

Does the IFD100 by chance log data in the background where we could send you the logs for more in depth analysis?
Nothing more than the IFD itself.  Also, I'm not sure how you would extract them.

I wasn't sure how to extract them either since going to Download Logs sends you back to the Jepp screen and exits.  If you'd find it useful, you may consider modifying that part of the interface to allow us to extract the logs for you.


Posted By: brou0040
Date Posted: 13 Dec 2019 at 7:13pm
Finally the weather was good enough to fly again, the IFD100 worked perfectly!  For the first time, my stratux wasn't working so I used the LIO_WIFI.  Hopefully the stratux is just the lighter charger.


Posted By: n7ifr
Date Posted: 13 May 2020 at 5:37pm
"Bottom line is that it appears that the ADS-B support, which enables traffic via stratux/stratus, makes the wifi connection between the 540 and the 100 less stable."

Not sure but this might help:

With my dual IFD540's, I usually use 540#1 (with ADSB, traffic, etc) WiFi ti talk with IFD100 & FF & FlyQ.  Last few flights, I noticed  on iPad, no matter which App, the ADSB via WiFi dropped out, and on IFD100, no traffic or Wx despite all good on data blocks and FP.

So, I changed to my IFD#2 WiFi (change iPad IFD100 Chassi to #2, etc), and all good on two more flights!

My conclusion is the WiFi from my IFD#1 is "weaker" or somehow less able to handle the bandwidth of all the data... and the WiFi in y IFD540 #2 much more capable or stable??

On my wiring of the IFD#1 vs #2, certain data-block items will not port to IFD100 from my #2 (even though ok on #2 IFD via Synch Port-3), like Fuel Data, but not an issue for me as I display fuel info on my #2IFD.

Hope that's not TMI, but basically, my #2IFD540 WiFi seems much more robust and handles the data bandwidth.

Tom W.


Posted By: brou0040
Date Posted: 14 Jun 2020 at 8:25pm
Update for anybody who finds this thread and may have the same issue.

I *think* I have found my issue, at least I was able to repeatably create and resolve the issue a few times on the ground.  I only say I think this is it since I thought I fixed it once before and was wrong.  Totally user error.  I have a VPN on the tablet and it appears that when I turned wifi off and on again, there would be a window of time after wifi is reconnected and before the VPN attempted to connect.  This is the small window where the IFD100 would work.   I added my airplane's network to the trusted wifi list so the VPN no longer tries to auto connect to its servers when on this network and no more issues.

I was hoping to test it out flying this morning, but a wildfire decided to change my plans.  I'll update this post if I find anything different once I get up flying.


Posted By: allenc3
Date Posted: 09 Aug 2020 at 2:01pm
You can not run two WiFi systems simultaneously like you can on Bluetooth. I dont know much about how Stratux operates, but what you have to do is setup your Stratux app as the server. You select your Stratux as your wifi option on your users setup on your IDF540, and on your Ipad, you select your Stratux Wifi. This way your IDF540, IDF100, and your Stratux  will see and talk with each other.

-------------
Claude


Posted By: n7ifr
Date Posted: 09 Aug 2020 at 2:20pm
Speaking of IFD-WiFi problems:

On 2 separate flights, both FF and FlyQ Apps "lost" WiFi reception.  Tried re-booting Apps, but NoJoy.
Had to re-boot my IFD #2 supplying WiFi and then all good.

Not sure why spontaneous WiFi drop-out... any ideas?

Tom W.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.01 - http://www.webwizforums.com
Copyright ©2001-2018 Web Wiz Ltd. - https://www.webwiz.net