Print Page | Close Window

Skytrax 200 Receiver failure

Printed From: Avidyne
Category: Avidyne General
Forum Name: SkyTrax Series ADS-B Receivers & Transceivers
Forum Description: Topics on the Avidyne SkyTrax 978 MHz Receivers & Transceivers
URL: http://forums.avidyne.com/forum_posts.asp?TID=2400
Printed Date: 14 Jun 2024 at 1:02am
Software Version: Web Wiz Forums 12.01 - http://www.webwizforums.com


Topic: Skytrax 200 Receiver failure
Posted By: swyloge
Subject: Skytrax 200 Receiver failure
Date Posted: 10 Sep 2022 at 3:39pm
I had a Skytrax 100b in my plane and it failed. It began to fail intermittently so I took the plane to the dealer. The dealer installed the upgrade to make the unit a Skytrax 200. The unit would work on start up but would fail after a few minutes and give a message of "Maintenance Required". After performing some diagnostics it was having a receiver failure. The dealer sent it in to Avidyne and Avidyne did an exchange, sending back a new Skytrax 200. The dealer installed and configured the new unit and it worked initially while on the ground. After a few minutes the unit failed, again showing the message "Maintenance Required". The dealer ran diagnostics on his laptop and it showed that the receiver had failed.

This new unit has been shipped back to Avidyne. I don't know what I will be getting back.

It seems that these units do not work.

Do you have any further information regarding these units?


-------------
Swyloge



Replies:
Posted By: AviSteve
Date Posted: 10 Sep 2022 at 5:20pm
I haven't heard of anything systemic with the SkyTrax units.  I'm curious what failures the diagnostics reported.  Hopefully your dealer has been in touch with tech support.  If unit #3 does the same thing, I'd be looking into an installation issue.

-------------
Steve Lindsley
Avidyne Engineering


Posted By: dmtidler
Date Posted: 10 Sep 2022 at 6:01pm
Originally posted by swyloge swyloge wrote:

I had a Skytrax 100b in my plane and it failed. It began to fail intermittently so I took the plane to the dealer. The dealer installed the upgrade to make the unit a Skytrax 200. The unit would work on start up but would fail after a few minutes and give a message of "Maintenance Required". After performing some diagnostics it was having a receiver failure. The dealer sent it in to Avidyne and Avidyne did an exchange, sending back a new Skytrax 200. The dealer installed and configured the new unit and it worked initially while on the ground. After a few minutes the unit failed, again showing the message "Maintenance Required". The dealer ran diagnostics on his laptop and it showed that the receiver had failed.

This new unit has been shipped back to Avidyne. I don't know what I will be getting back.

It seems that these units do not work.

Do you have any further information regarding these units?

I was an early adopter of the SkyTrax200 when I exchanged my MLB100/SkyTrax100 for a SkyTrax200 unit just over a year ago. From my perspective, it has worked rather flawlessly. 

With that said, I too get a momentary "Maintenance Required" message in the traffic thumbnail at every IFD power up for approximately 15-30 seconds after my IFD540 determines its GPS position (indicated by the red X in the traffic thumbnail being replaced with a normal traffic display).  After that, the "Maintenace Required" message disappears until the same point in the next IFD power up. In my case, I take this to be normal behavior as the SkyTrax200 probably needs a few moments of proper GPS information from the IFD before removing the "Maintenance Required" flag.


Posted By: swyloge
Date Posted: 23 Sep 2022 at 6:07pm
I had a new Skytrax 200 box installed today by the dealer. It seems to work as it should, I am seeing all traffic and it has not failed. However, it is displaying my Own Ship (N792SR) on the IFD with an annunciation of "Traffic 0.0NM same altitude". It also displays Maint Required. I think the Own Ship must be a setting that needs to be done via computer attached to the unit. Is this correct or can I set this on the IFD550?

How do I resolve the "Main Required" message?

Thank you.



-------------
Swyloge


Posted By: dmtidler
Date Posted: 23 Sep 2022 at 7:25pm
Not sure about what is causing the continuous "Maint Required" message. I would think that Avidyne Tech Support would be able to offer ideas and solutions. As far as the ownship being continuously displayed; I believe the SkyTrax200 uses the aircraft's 6 digit hex ICAO code (Mode S code) found on FAA aircraft registration / N-number lookup website to suppress showing the aircraft's ownship. You may be able to verify that your transponder is set to send the correct ICAO code; however, it will probably take an Avidyne dealer to connect to your SkyTrax200 through its USB-C port to verify that the SkyTrax200 also has the correct ICAO code set for your aircraft. 

BTW - using anonymous mode ADSB-out will most likely produce an ownship display as anonymous ADSB-out randomizes the aircraft ICAO code sent from the aircraft which will not match the ICAO code the SkyTrax200 associates with that aircraft.    


Posted By: swyloge
Date Posted: 25 May 2023 at 3:49pm
My Skytrax 200 has been working normally for the past 8 months. Today it failed intermittently and displayed “maintenance required”. It would come on and off. The Skywatch remained working the entire time. Does anyone have any suggestions?

-------------
Swyloge


Posted By: AviSteve
Date Posted: 26 May 2023 at 9:25am
The "Maint Required" message on the IFD is driven directly from a corresponding indication in the SkyTrax.   The SkyTrax triggers that indication based on a number of conditions, including:
  • GPS invalid/unusable (position, geo altitude, velocity)
  • GPS integrity is below the required accuracy for ADS-B
  • Pressure altitude unavailable
  • Failure of a connected TAS/TCAS
  • ICAO not configured properly
  • Receiver failure

I suspect that most instances of this message are the result of one of the first three conditions above.


-------------
Steve Lindsley
Avidyne Engineering


Posted By: Sanjiv
Date Posted: 01 Jun 2023 at 7:56am
Did you get your issue resolved? What was causing it? 

-------------
PA28-236 @N14


Posted By: Silvaa109
Date Posted: 20 Jun 2023 at 3:57pm
I had the problem with my Skytrax 200. Returned it to Avidyne and they exchanged it. The new unit was installed and it seemed to work ok but gave out after a couple hours of use with the same issues. The dealer troubleshooted with Avidyne and they concluded the original wiring for the Skytrax 100 was not compatible with the Skytrax 200 with the 10.3.2.1 Ifd540 software upgrade so they had to change the pinning of one of the wires from the Skytrax to the IFD 540. I made a couple of flights some the repair and haven’t experienced any problems. 



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.01 - http://www.webwizforums.com
Copyright ©2001-2018 Web Wiz Ltd. - https://www.webwiz.net