Avidyne Homepage
Forum Home Forum Home > Avidyne General > IFD 5 Series & IFD 4 Series Touch Screen GPS/NAV/COM
  New Posts New Posts RSS Feed - UTC Mismatch
  FAQ FAQ  Forum Search   Register Register  Login Login

UTC Mismatch

 Post Reply Post Reply
Author
Message
birddog486 View Drop Down
Newbie
Newbie


Joined: 23 Jan 2021
Location: 53511
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote birddog486 Quote  Post ReplyReply Direct Link To This Post Topic: UTC Mismatch
    Posted: 21 Feb 2021 at 12:25pm
I seem to be getting this message fairly often on startup (UTC Mismatch). I believe I have the latest software but it's possible I didn't install it yet. 

Has there been an update for this or do I have a problem? This IFD-440 is connected to two Dynon HDX screens via the arinc429

Back to Top
chflyer View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jan 2013
Location: LSZK
Status: Offline
Points: 894
Post Options Post Options   Thanks (0) Thanks(0)   Quote chflyer Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 2021 at 1:36pm
Do you have just one IFD? Is the timestamp correct after power up?

With two IFD‘s interconnected, you‘ll get this msg if there is a time discrepancy between the two. My IFD440 loses time between flights and remains wrong on startup until GPS satellite reception has been established for a certain time period (time to retrieve the almanac?). I suspect a battery problem and you might check that on your IFD440.
Vince
Back to Top
dmtidler View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Feb 2016
Location: USA
Status: Offline
Points: 479
Post Options Post Options   Thanks (0) Thanks(0)   Quote dmtidler Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 2021 at 3:24pm
Originally posted by birddog486 birddog486 wrote:

I seem to be getting this message fairly often on startup (UTC Mismatch). I believe I have the latest software but it's possible I didn't install it yet. 

Has there been an update for this or do I have a problem? This IFD-440 is connected to two Dynon HDX screens via the arinc429


Have you tried power cycling the affected IFD when you get this advisory to correct the IFD's internal clock? The following is from the IFD PG:


Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 2021 at 5:39pm
the IFD440 in my friend's aircraft often presents the UTC mismatch error, I power cycle the unit and it goes away however it comes back several weeks later.
Back to Top
birddog486 View Drop Down
Newbie
Newbie


Joined: 23 Jan 2021
Location: 53511
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote birddog486 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Feb 2021 at 11:02pm
Only have one IFD in the plane and I have power cycled the unit but, it comes back a few flights later.
Back to Top
kgrant View Drop Down
Newbie
Newbie


Joined: 15 Dec 2015
Location: Bolivar, MO
Status: Offline
Points: 32
Post Options Post Options   Thanks (0) Thanks(0)   Quote kgrant Quote  Post ReplyReply Direct Link To This Post Posted: 26 Feb 2021 at 8:08am
I get it fairly often too. Since I figured my EI clock was somehow tied to it, I reset the EI time to match the 440 & recycle. I guess the recycle is fixing it rather than resetting the EI clock.. k
Back to Top
paulr View Drop Down
Senior Member
Senior Member


Joined: 24 Jan 2014
Status: Offline
Points: 464
Post Options Post Options   Thanks (0) Thanks(0)   Quote paulr Quote  Post ReplyReply Direct Link To This Post Posted: 26 Feb 2021 at 8:30am
It happens to me every so often at startup and I just ignore it.
Back to Top
chflyer View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jan 2013
Location: LSZK
Status: Offline
Points: 894
Post Options Post Options   Thanks (0) Thanks(0)   Quote chflyer Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 3:33am
I was unaware of the recycle guidance and that works for me too. It seems that a lot of us have the issue, enough to suggest Avidyne fix it. It's an annoyance at startup that we don't need.
Vince
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 9:05am
You should rarely, if ever, see that message, so the fact that there is a recent increase in sightings has our attention.  We're actively trying to determine the root cause.
Steve Lindsley
Avidyne Engineering
Back to Top
chflyer View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jan 2013
Location: LSZK
Status: Offline
Points: 894
Post Options Post Options   Thanks (0) Thanks(0)   Quote chflyer Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 9:31am
As information, just FWIW, I have had the issue with my 440 for over a year now. I'm running 10.2.3.1.

Up until a couple weeks ago, I never had the issue with my 540. Whenever the plane sat for over 2 weeks or so, the 440 would power on with a significantly old date/timestamp (i.e. days or weeks out of date). I always attributed it to a battery issue, because after some running time the 440 date/timestamp would correct itself without any power cycle.

The last time it happened, I tried the (new to me) power cycle resolution suggested in the PG and it worked except that the 440 time was now a couple minutes newer than the 540 so I still got the UTC Mismatch message. I power cycled the 540 as well and it came back with the same time as the 440 ... issue solved.

Just as a thought, it might be that more people are reporting the issue now because the aircraft are flying less and there is a longer gap between power cycles for more aircraft.



Edited by chflyer - 01 Mar 2021 at 9:34am
Vince
Back to Top
steve.crimm@stephens View Drop Down
Newbie
Newbie


Joined: 25 Jul 2018
Location: South Carolina
Status: Offline
Points: 22
Post Options Post Options   Thanks (0) Thanks(0)   Quote steve.crimm@stephens Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 11:40am
FYI...After my RV-10 with an IFD 440 sat for 30 days I got the UTC error last weekend.  First time ever getting the error and it has sat for longer periods of time.
Vans RV-10
PMA7000BT
IFD440
Dynon Skyview HDX
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Mar 2021 at 4:19pm
I received the UTC mismatch error yesterday for my first flight of the day, the last flight was prior to this was on February 13th and I had powered up the GPS on March 5th to update the database. 

Interesting note on the March 5th database update, My friend did the update for me and sent me a picture to confirm it was completed, the date of the text message on my phone was 12:12pm (UTC -5) but the GPS splash screen said 17:14z, 2 minutes ahead of the cell phone.  I'm going to guess the unit was turned off before it had acquired a GPS signal, but that 2+ minutes might be what triggered the UTC mismatch on the next power up.

just food for thought.....

Jeff
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 15 Mar 2021 at 10:22am
Originally posted by AviSteve AviSteve wrote:

You should rarely, if ever, see that message, so the fact that there is a recent increase in sightings has our attention.  We're actively trying to determine the root cause.


So any thoughts on the time difference displayed vs actual causing the issue?
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2021 at 9:43am
Nothing definitive yet about a systemic issue.  We're waiting on a couple of RMA units for further analysis.
Steve Lindsley
Avidyne Engineering
Back to Top
windhamcr View Drop Down
Newbie
Newbie
Avatar

Joined: 12 Nov 2021
Location: North East Tenn
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote windhamcr Quote  Post ReplyReply Direct Link To This Post Posted: 12 Nov 2021 at 9:13pm
Any update on this issue?

Best regards,
Chuck
Chuck
Back to Top
nrproces View Drop Down
Senior Member
Senior Member


Joined: 19 Sep 2016
Location: Marion, MT
Status: Offline
Points: 107
Post Options Post Options   Thanks (0) Thanks(0)   Quote nrproces Quote  Post ReplyReply Direct Link To This Post Posted: 13 Nov 2021 at 8:09am
It happens often to me, but if I shut the system down and restart it, it usually corrects itself on the second start.  Just my situation, yours may vary...
Sauce
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 10:46am
Originally posted by windhamcr windhamcr wrote:

Any update on this issue?
Yes we did find the issue and will take a hardware mod to fix it.  Coordinate an RMA with your dealer to get the unit updated with "Mod 25".
Steve Lindsley
Avidyne Engineering
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 11:28am
Originally posted by AviSteve AviSteve wrote:

Originally posted by windhamcr windhamcr wrote:

Any update on this issue?
Yes we did find the issue and will take a hardware mod to fix it.  Coordinate an RMA with your dealer to get the unit updated with "Mod 25".


Ugh, ship the unit out... ok, at least the problem was found.

There are two planes that I fly both with IFD440s, my plane has had the error only a handful of times, my friend's plane that I also fly seems to encounter the problem a lot more often.

So I understand how soon (if at all) I ship the units back, my questions are, besides getting the error message is there any degradation/functionality loss or can I simply consider it a nuisance  message?  Looking at the serial number label for my unit (took a picture before it was installed) it was manufactured the 21st week of 2019 and is a Rev:09 unit, there are no mods checked off.  If I send the unit back for Mod 25, what else is done? Are there other MODs that will get performed?  Are there any others that should be done?  I'm assuming the software is also brought up to the current version as well, eg wait for the elusive 10.3.x.x .

-PA
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 11:49am
If you RMA the unit, it will come back to you with all mandatory mods applied and the latest software.

It's a little more than a nuisance message because the time actually is off.  But, if you get a GPS position and then cycle power, the condition should be cleared.  So, it comes down to your tolerance level for dealing with that.
Steve Lindsley
Avidyne Engineering
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 12:40pm
Originally posted by AviSteve AviSteve wrote:

If you RMA the unit, it will come back to you with all mandatory mods applied and the latest software.

It's a little more than a nuisance message because the time actually is off.  But, if you get a GPS position and then cycle power, the condition should be cleared.  So, it comes down to your tolerance level for dealing with that.


Steve, I just want to make sure I understand the consequences of receiving the UTC mismatch error as you now have me second guessing what I've been doing, the first few times I did cycle the power of the unit but after that when I got the error I would simply acknowledge it and move on, the unit always got a GPS lock and appeared to work correctly.

Are you saying that for the system to work properly I must cycle the power before continuing?

If it is just a time and date issue for processing ADS-B in data then I'm not as concerned since In my case I am feeding traffic and WX to the IFD from an NGT-9000 and I really don't view the traffic or wx on the IFD as I find it a lot more convenient to view the data on the NGT

-PA
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 12:42pm
...and I was really hoping it would have been a software fix
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 12:58pm
If you just acknowledge and move on, it's just that time would be incorrect.  GPS will still work just fine.  ETAs would be off.  It's possible that datalink Wx reports would be marked stale or even be rejected if the time was way off.  Since you're not using IFD for Wx, that won't be an issue for you.

We probably could have masked it in software, but the hardware fix was really the right answer.
Steve Lindsley
Avidyne Engineering
Back to Top
nrproces View Drop Down
Senior Member
Senior Member


Joined: 19 Sep 2016
Location: Marion, MT
Status: Offline
Points: 107
Post Options Post Options   Thanks (0) Thanks(0)   Quote nrproces Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 1:48pm
Steve, so this issue requires an RMA to fix, are we on the hook for some $ to do that or is it going to be done, at our "shipping" expense only?
Thanks, Chris
Sauce
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2021 at 5:04pm
That's all going to depend on your warranty status, but for a typical unit still under factory warranty, when coordinated through an Avidyne dealer, you'll just be on the hook for shipping one way.

Best to email warranty@avidyne.com to determine your specific situation.
Steve Lindsley
Avidyne Engineering
Back to Top
nrproces View Drop Down
Senior Member
Senior Member


Joined: 19 Sep 2016
Location: Marion, MT
Status: Offline
Points: 107
Post Options Post Options   Thanks (0) Thanks(0)   Quote nrproces Quote  Post ReplyReply Direct Link To This Post Posted: 17 Nov 2021 at 8:16am
Well, I guess I have had mine too long. I guess that I will have to just do the restart.
Thanks, Chris
Sauce
Back to Top
PA23 View Drop Down
Senior Member
Senior Member


Joined: 12 Oct 2019
Location: MMU
Status: Offline
Points: 183
Post Options Post Options   Thanks (0) Thanks(0)   Quote PA23 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Nov 2021 at 1:43pm
Originally posted by AviSteve AviSteve wrote:

If you just acknowledge and move on, it's just that time would be incorrect.  GPS will still work just fine.  ETAs would be off.  It's possible that datalink Wx reports would be marked stale or even be rejected if the time was way off.  Since you're not using IFD for Wx, that won't be an issue for you.

We probably could have masked it in software, but the hardware fix was really the right answer.


Thanks Steve,

I can't comment as  to why a hardware fix was the better solution than fixing the error in software but I'm guessing the fix had something to do with the timing or powering the RTC (Real Time Clock) as it is more prevalent when the plane sits for a while.

Since my unit is still under warranty for almost 2 more years I will go ahead and plan to have the mod installed.  However since the error doesn't appear to  directly effecting how I use the unit I will probably wait until the plane goes in for annual so I'm not down unnecessarily, and bonus maybe I can take advantage and upgrade to 10.3.x.x at the same time....(Anticipation...)



-PA23
Back to Top
keithrkoenig View Drop Down
Newbie
Newbie


Joined: 16 Nov 2021
Location: Byron C83
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote keithrkoenig Quote  Post ReplyReply Direct Link To This Post Posted: 18 Nov 2021 at 7:23pm
Wait what? I just took delivery of a new 440 last month and saw this error once or twice. Thought it was because I was in the hangar. Are you saying I need to send it back after less than a month after purchase?
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1640
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 19 Nov 2021 at 9:47am
Originally posted by keithrkoenig keithrkoenig wrote:

Wait what? I just took delivery of a new 440 last month and saw this error once or twice. Thought it was because I was in the hangar. Are you saying I need to send it back after less than a month after purchase?
Possibly.  Give tech support a call.  They will be able to check whether your IFD has the mod applied.
Steve Lindsley
Avidyne Engineering
Back to Top
MikeS View Drop Down
Newbie
Newbie


Joined: 29 Jan 2021
Location: Melbourne
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote MikeS Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2021 at 9:32am
Originally posted by keithrkoenig keithrkoenig wrote:

Wait what? I just took delivery of a new 440 last month and saw this error once or twice. Thought it was because I was in the hangar. Are you saying I need to send it back after less than a month after purchase?

It probably is because you're in the hangar. UTC time is updated by GPS signal. If you're in a hangar with no GPS reception, your UTC time won't update.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.066 seconds.